[Pdns-users] Installing PowerDNS 4.x authorative server on Debian Jessie

Volker Janzen volker at janzen.onl
Mon Aug 1 14:24:06 UTC 2016


doing so failed, too.

First problem is, that the bind backup demo config file in pdns.d directory need to be deleted. Otherwhise the gmysql backend will not get activated, whatever you do.

When I run pdns-server from command line, PowerDNS is now starting correct and it seems to respond correct.

Just dpkg is unable to configure pdns-server and systemd is unable to start pdns.

Going back to the start: why can dpkg fail to configure a fresh installed pdns-server package?

I purge everything:

root at pdns:~# dpkg --purge pdns-backend-mysql pdns-server
(Reading database ... 93153 files and directories currently installed.)
Removing pdns-backend-mysql (4.0.1-1pdns.jessie) ...
Purging configuration files for pdns-backend-mysql (4.0.1-1pdns.jessie) ...
Removing pdns-server (4.0.1-1pdns.jessie) ...
Purging configuration files for pdns-server (4.0.1-1pdns.jessie) ...
Processing triggers for man-db ( ...

/etc/powerdns no longer exists.

root at pdns:~# apt-get install pdns-server
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Suggested packages:
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/1425 kB of archives.
After this operation, 6751 kB of additional disk space will be used.
Preconfiguring packages ...
Selecting previously unselected package pdns-server.
(Reading database ... 93113 files and directories currently installed.)
Preparing to unpack .../pdns-server_4.0.1-1pdns.jessie_amd64.deb ...
Unpacking pdns-server (4.0.1-1pdns.jessie) ...
Processing triggers for man-db ( ...
Processing triggers for systemd (215-17+deb8u4) ...
Setting up pdns-server (4.0.1-1pdns.jessie) ...

Creating config file /etc/powerdns/pdns.conf with new version

Creating config file /etc/default/pdns with new version

Creating config file /etc/powerdns/pdns.d/pdns.local.conf with new version

Creating config file /etc/powerdns/pdns.d/pdns.simplebind.conf with new version
Job for pdns.service failed. See 'systemctl status pdns.service' and 'journalctl -xn' for details.
invoke-rc.d: initscript pdns, action "start" failed.
dpkg: error processing package pdns-server (--configure):
 subprocess installed post-installation script returned error exit status 1
Processing triggers for systemd (215-17+deb8u4) ...
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)
root at pdns:~# systemctl status pdns.service
* pdns.service - PowerDNS Authoritative Server
   Loaded: loaded (/lib/systemd/system/pdns.service; enabled)
   Active: activating (start) since Mon 2016-08-01 16:22:04 CEST; 1ms ago
     Docs: man:pdns_server(1)
 Main PID: 1870 (systemd)
   CGroup: /system.slice/pdns.service
           `-1870 /sbin/init

Aug 01 16:23:04 pdns systemd[1]: pdns.service: main process exited, code=exited, status=227/N
Aug 01 16:23:04 pdns systemd[1]: Failed to start PowerDNS Authoritative Server.
-- Subject: Unit pdns.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- Unit pdns.service has failed.
-- The result is failed.
Aug 01 16:23:04 pdns systemd[1]: Unit pdns.service entered failed state.

Any advice?


> Am 01.08.2016 um 16:03 schrieb Volker Janzen <volker at janzen.onl>:
> Hi,
> I am beginning to understand what caused my problem.
> First, the library error is caused by a binary in /usr/local/sbin/pdns_server, that is a remain of an older build I did before switching to the 3.x static build deb packages. Neither sysv init nor systemd will access this binary.
> Second: I am updating from 3.x to 4.x and I left old pdns.conf in place, which contained a gmysql configuration, of course. The new installation procedure is to install pdns-server first and after this the required backend package. It seems that it is not possible to upgrade a running pdns 3.x gmysql installation to 4.x. The pdns-server package fails with gmysql configuration and the mysql backend package wants to be installed after a fully configured pdns-server. Which will never happen due to the gmysql config.
> I think I need to backup my current configuration, purge all pdns packages, make sure whole /etc/powerdns directory is empty and then migrate my configuration to the new pdns.d/pdns.local.conf file.
> But I'm still not sure, because systemd / journalctl refuse to print a plain text error message. I got all this from running pdns-server on command line.
> Regards
>    Volker
>>> Am 01.08.2016 um 14:53 schrieb Brian Candler <b.candler at pobox.com>:
>>> On 01/08/2016 13:38, Volker Janzen wrote:
>>> Hi,
>>>> Am 01.08.2016 um 13:09 schrieb Peter van Dijk <peter.van.dijk at powerdns.com>:
>>>> Hello Volker,
>>>> can you show:
>>>> dpkg -l | grep pdns
>>> iU  pdns-backend-mysql                     4.0.1-1pdns.jessie                   amd64        generic MySQL backend for PowerDNS
>>> iF  pdns-server                            4.0.1-1pdns.jessie                   amd64        extremely powerful and versatile nameserver
>>> rc  pdns-static                            3.4.7-1                              amd64        PowerDNS nameserver (static version)
>> iU = installation requested, package unpacked but not configured
>> iF = installation requested; package unpacked but halF-configured
>> rc = removed (but configuration files may still remain, you can use 'apt-get purge' if you want to delete them)
>> For the dependencies, have a look at:
>> apt-cache show pdns-server
>> apt-cache show pdns-backend-mysql
>> Does it depend on a specific version of libboost?
> _______________________________________________
> Pdns-users mailing list
> Pdns-users at mailman.powerdns.com
> https://mailman.powerdns.com/mailman/listinfo/pdns-users

More information about the Pdns-users mailing list