[Pdns-users] Installing PowerDNS 4.x authorative server on Debian Jessie

Mario Caruso caruso at tiscali.com
Mon Aug 1 11:29:42 UTC 2016

I did the upgrade on my jessie servers, and I did not have 
any error, everything worked at first shot, here is the state 
of my packages as suggested by Peter van Dijk; hope this 
will be useful .



taken from a server with following state:

Distributor ID: Debian
Description:    Debian GNU/Linux 8.5 (jessie)
Release:        8.5
Codename:       jessie

dpkg -l | grep pdns
ii  pdns-backend-mysql                   4.0.1-1pdns.jessie          amd64        generic MySQL backend for PowerDNS
ii  pdns-server                          4.0.1-1pdns.jessie          amd64        extremely powerful and versatile nameserver
ii  pdns-tools                           4.0.1-1pdns.jessie          amd64        Tools for DNS debugging by PowerDNS

dpkg -l | grep boost
ii  libboost-iostreams1.55.0:amd64       1.55.0+dfsg-3               amd64        Boost.Iostreams Library
ii  libboost-program-options1.55.0:amd64 1.55.0+dfsg-3               amd64        program options library for C++

ldd /usr/sbin/pdns_server
        linux-vdso.so.1 (0x00007ffe3b09b000)
        libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f8ecb6e2000)
        libcrypto.so.1.0.0 => /usr/lib/x86_64-linux-gnu/libcrypto.so.1.0.0 (0x00007f8ecb2e6000)
        libsystemd.so.0 => /lib/x86_64-linux-gnu/libsystemd.so.0 (0x00007f8ecb0c2000)
        libbotan-1.10.so.0 => /usr/lib/libbotan-1.10.so.0 (0x00007f8ecabc1000)
        libsqlite3.so.0 => /usr/lib/x86_64-linux-gnu/libsqlite3.so.0 (0x00007f8eca8f8000)
        liblua5.2.so.0 => /usr/lib/x86_64-linux-gnu/liblua5.2.so.0 (0x00007f8eca6c5000)
        libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f8eca3ba000)
        libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f8eca0b9000)
        libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f8ec9ea3000)
        libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f8ec9c86000)
        libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f8ec98db000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f8ecbdbd000)
        librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f8ec96d3000)
        liblzma.so.5 => /lib/x86_64-linux-gnu/liblzma.so.5 (0x00007f8ec94b0000)
        libgcrypt.so.20 => /lib/x86_64-linux-gnu/libgcrypt.so.20 (0x00007f8ec91ce000)
        libresolv.so.2 => /lib/x86_64-linux-gnu/libresolv.so.2 (0x00007f8ec8fb7000)
        libbz2.so.1.0 => /lib/x86_64-linux-gnu/libbz2.so.1.0 (0x00007f8ec8da7000)
        libgmp.so.10 => /usr/lib/x86_64-linux-gnu/libgmp.so.10 (0x00007f8ec8b24000)
        libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f8ec8909000)
        libgpg-error.so.0 => /lib/x86_64-linux-gnu/libgpg-error.so.0 (0x00007f8ec86f7000)

Il Mon, 1 Aug 2016 11:05:08 +0000
Volker Janzen <volker at janzen.onl> ha scritto:

> Hi,
> today I wanted to update my PowerDNS authorative cluster from 3.x to 4.x. After reviewing the upgrade instructions I found no database changes (mysql backend), so I decided to proceed. As of my cluster is still on Debian wheezy, I wanted to upgrade to Jessie before upgrading PowerDNS.
> The update of the master seem to have worked fine, until I rebooted the VM. PowerDNS failed to start.
> My beloved systemd / journalctl companions failed to show the reason why the authorative server did not start.
> I then simpy tried on command line to start the server:
> root at pdns:~# pdns_server
> pdns_server: error while loading shared libraries: libboost_serialization.so.1.49.0: cannot open shared object file: No such file or directory
> I'm not sure how to solve this issue. Debian online package search shows up there should be a library of this version in Jessie, but when clicking the package it shows an error, this version is not installable in current Jessie as far as I can say.
> Is there some kind of dependency problem in PowerDNS?
> I followed these instructions with using the PowerDNS repo: https://doc.powerdns.com/md/authoritative/installation/
> Regards
>     Volker
> _______________________________________________
> Pdns-users mailing list
> Pdns-users at mailman.powerdns.com
> https://mailman.powerdns.com/mailman/listinfo/pdns-users

More information about the Pdns-users mailing list