[Pdns-users] API issue

Melvin Mughal melvin at mughal.nu
Thu Mar 5 16:43:36 UTC 2015

Ok, I'm an idiot. Found the problem. I did apt-get the package to install
and assumed it was the latest and greatest. The dump/monitor doesn't show
version when it has an error. After I deleted all the API lines, the server
started. When I dumped the log it showed the version.. PowerDNS version
3.3.1...which has no API support. Eventually, Koko was right ;)

I tried the newest version 3.4.3 through instructions (
https://doc.powerdns.com/md/authoritative/installation/) via dpkg install.
But when I try to install the pdns-backend-mysql package it won't install,
saying it needs pdns 3.3.1. I tried to first install pdns 3.3.1 and get rid
off it via dpkg replacing it with pdns 3.4.3. But that doesn't work. Is
there a newer version I need to get?

2015-03-05 12:30 GMT+01:00 Jan-Piet Mens <jpmens.dns at gmail.com>:

> > *Mar 05 06:04:28 Fatal error: Trying to set unexisting parameter
> > 'webserver-allow-from'*
> IIRC (I don't feel like going back to study all this) you've been
> telling us all the time that all was fine...
> Before bothering with the API, make sure your PowerDNS server starts
> without errors. Check the documentation. If you've built this yourself,
> make sure you build with the necessary options to enable the features
> you need. Otherwise grab a built package from the PowerDNS downloads
> page as these include what you're probably missing.
> When that's done, step by step, go on to the next step.
>         -JP
> _______________________________________________
> Pdns-users mailing list
> Pdns-users at mailman.powerdns.com
> http://mailman.powerdns.com/mailman/listinfo/pdns-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.powerdns.com/pipermail/pdns-users/attachments/20150305/3fc6b2a8/attachment-0001.html>

More information about the Pdns-users mailing list