[Pdns-users] API issue

Melvin Mughal melvin at mughal.nu
Thu Mar 5 09:57:49 UTC 2015

I actually just copied/adjusted your config and run the same curl commands.
So my config in the pdns.conf for the API:

*webserver-address=ip address of the server*

*webserver-allow-from=, ::/0*





The curl commands I run form my own system to the server:

*curl -s -H 'X-API-Key: otto' http://xxx.xx.xx.xx:8081/servers/localhost

curl -s -H 'X-API-Key: otto'

And it just returns nothing. So the crud in the API key wasn't an issue I
guess. No errors and also no result. But there is a zone file in there, so
it should be returning something. I restarted pdns a million times and
still no 8081 port listening with this config.

2015-03-05 7:34 GMT+01:00 Jan-Piet Mens <jpmens.dns at gmail.com>:

> > This version of PowerDNS we use is PowerDNS Authoritative Server 3.4.2.
> > This is the entire pdns.conf file in /etc/powerdns:
> >
> > http://pastebin.com/14LqMbLp
> Line 623 has crud behind it; that better not be in the configuration.
> Also show us the *exact* curl command you're using from the
> command-line, and the API key (if you're using line 623) better be
> protected from the shell. :)
>         -JP
> _______________________________________________
> Pdns-users mailing list
> Pdns-users at mailman.powerdns.com
> http://mailman.powerdns.com/mailman/listinfo/pdns-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.powerdns.com/pipermail/pdns-users/attachments/20150305/dd07a5ce/attachment-0001.html>

More information about the Pdns-users mailing list