[Pdns-users] Slaves are not updating after making changes on master

Mislav | sys admin mislavorsolic at gmail.com
Tue Jun 23 11:42:29 UTC 2015

Going even further with debugging, I've found out that my mysql 
configurations were set to localhost only, so I though maybe that is the 
problem, but nothing, it didn't help.

I've restored new VPS and installed from wheezy backports pdns version 
3.4.4., configured everything and slaves just don't update after 
additional records. As I mentioned already, if I add new slave zone, all 
records are transferred, but afterwards none.

If I sent notify for this domain, result is always:
pdns[7807]: 1 domain for which we are master needs notifications
pdns[7807]: No master domains need notifications

and nothing gets updated.

Servers are indeed behind the firewall, but I've tried to allow all 
traffic on port 53 and no success (I've even disabled completely 
firewall, so firewall is not a problem for sure).

On 12.06.2015 22:05, Mislav Orsolic | Linux System Administrator wrote:
> Where exactly can I see/find this autoserial setting?
> I've checked both tables records (change_date) and domains 
> (notified_serial) both have some values, it's not set to 0 or NULL on 
> master and on slave in domains table notified_serial for both new and 
> old domains is set to NULL  + in records table, change_date is set to 
> NULL for old/new domains.
> I've also tried to add on the slave
> On 12.06.2015 21:37, Aki Tuomi wrote:
>> On Fri, Jun 12, 2015 at 09:23:35PM +0200, Mislav Orsolic | Linux 
>> System Administrator wrote:
>>> I've recently debugged even more this scenario and it seems like I'm
>>> unable to find solution.
>>> What bothers me is this:
>>> - every domain that was added in the past, after adding new record,
>>> new record is automatically transferred to the slave with any
>>> problem within next minute or two
>>> - every new domain that I add have problem when I add new record on
>>> the master server, it is not transferred to the slaves and the only
>>> way it is working is manually through pdns_control notify host
>>> domain OR changing directly in the database SOA record or last
>>> checked - in the end this is not solution, as I want it to be
>>> transferred automatically, just like it's working for old domains
>>> What could be the problem, any suggestions? If any log/setting is
>>> needed, let me know and I will provide the same.
>> Maybe those older domains are using autoserial by having their serial 
>> set to 0? In this case,
>> powerdns sets serial to highest change_date.
>> Aki

More information about the Pdns-users mailing list