[Pdns-users] Unable to connect to SQLite database does not exist yet

Lists lists at lolling.org
Thu Aug 28 21:52:26 UTC 2014

Right now, this is on  a test server in my test environment.  I have two 
test servers using the SQLite backend and both have the same issue.  I 
am setting these up for a POC / evaluation, so I am new to this 
product.  The documentation I have been reading does not really say much 
about where the SQLite database should reside or ownership / 
permissions.  At least I haven't seen any information like that yet.

I moved my SQLite database file to /tmp and changed the ownership to the 
pdns user and pdns group and now pdns starts up.

So are there any best practices for using the SQLite backend?


On 8/28/2014 3:01 PM, bert hubert wrote:
> On Thu, Aug 28, 2014 at 02:48:50PM -0500, Lists wrote:
>> launch=gsqlite3
>> gsqlite3-database=/root/pdns.db
>> I have also tried changing permissions and ownership of my pdns
>> database file, thinking it was a permissions issue but I still get
>> the following errors in /var/log/messages.
>> gsqlite3: connection failed: SQLite database '/root/pdns.db' does
>> not exist yet
>> Caught an exception instantiating a backend: Unable to launch
>> gsqlite3 connection: SQLite database '/root/pdns.db' does not exist
>> yet
> Do you perhaps run with a chroot setting? Can you double triple check the
> file actually exists on that same same server?
> If possible, could you 'strace' to see which file PowerDNS tries to open?
> 	Bert

More information about the Pdns-users mailing list