[Pdns-users] 1 sec delay before DNS-answer at pdns-recursor

Shamus Smith smithshamus at yahoo.de
Wed Jun 26 20:58:32 UTC 2013

Hello Winfried,

> PowerDNS Recursor not listening at ::1 by default. But localhost resolves (/etc/hosts) to ::1 at the first try. So dig's first query fails.
> After 1 second (don't know why 1 second because default timeout is 3s), dig tries again at and it works.


> You have 3 possibilities:
> 1.) Force the Recursor to listen at ::1 (--local-address=,::1)


> 2.) Explicitly dig IPv4 (dig @ ...)

Tried that before, worked.

> 3.) Delete ::1 from /etc/hosts


Thank you very much Winfried! Maybe PowerDNS Recursor should also listen to ::1 by default, Dnsmasq seems to bind to all local interfaces by default.

@Michael, tried to use forward-zones-recurse before, but forget to mention it. It had the same delay.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.powerdns.com/pipermail/pdns-users/attachments/20130626/26f09079/attachment-0001.html>

More information about the Pdns-users mailing list