[Pdns-users] NOTIFY by pdns master with ldap backend in next authoritative server releases?

Nikolaos Milas nmilas at admin.noa.gr
Fri Oct 1 23:00:46 UTC 2010

  Thanks again for your help, JP.

I describe in short some more things I tried (I still need your guidance):

Initially, I found out that the plugin was not being loaded in openldap 
(as recorded in ldap.log):

    /etc/openldap/slapd.conf: line 182: keyword <plugin> ignored


    # slaptest -d 255 -f slapd.conf
    line 186 (plugin postoperation /usr/local/lib/slapi-dnsnotify.so
    plugin_init base-dn=ou=dns1,dc=example,dc=com
    zone-attribute=associatedDomain notify-delay=10)
    slapd.conf: line 186: keyword <plugin> ignored
    config file testing succeeded

Trying to solve the problem (why the plugin is not loaded), I came to 
the conclusion that I should probably add a "moduleload 
slapi-dnsnotify.la" directive in slapd.conf. So I copied the files 
"slapi-dnsnotify.*" to the directory where all openldap modules exist 
(/usr/lib64/openldap/) and tried again. But now openldap doesn't start 
at all:

    # slaptest -d 255 -f slapd.conf
    line 59 (moduleload slapi-dnsnotify.la)
    loaded module slapi-dnsnotify.la
    module slapi-dnsnotify.la: init_module() failed
    slapd.conf: line 59: <moduleload> handler exited with 1!
    slaptest: bad configuration file!

Why openldap refuses to load the plugin (one way or another)? Am I doing 
something wrong?


On 1/10/2010 6:50 ΌΌ, Jan-Piet Mens wrote:
>> Changing the SOA serial doesn't seem to trigger any NOTIFY to NS Servers
>> defined for the zone.
>> Also, I see no sign of logging anywhere...
>> It's as if the configuration statement included in slapd.conf is accepted,
>> but never doing something.
> No hints really, as I haven't used that bit for some time. It worked for
> me once without problems at all. I'd try the following:
> 1. Ensure the slapi plugin is indeed being loaded by your slapd. (Check
>     the slapd log.)
> 2. Ensure you've compiled slapi-plugin with WITH_SYSLOG defined, or it
>     won't log.
> 3. I assume you've started the notify-dns-slaves daemon? That is the one
>     which will send out the NOTIFY.
> 4. Once again, check the logs (var/log/messages); there must be
>     something there...
> Good luck,
>          -JP

More information about the Pdns-users mailing list