[Pdns-users] powerdns master, bind slave, slave not updating...

bert hubert bert.hubert at netherlabs.nl
Mon Mar 3 23:26:00 UTC 2008

On Mon, Mar 03, 2008 at 02:58:18PM -0800, Mathew Hennessy wrote:
> I've tried converting from BIND9 to PowerDNS configured as a slave with
> opendbx/sqlite3, and I'm still not getting any love.  How can I trick the
> master into not sending SERVFAIL for this demonstration setup?

If PowerDNS is not authoritative, it will send out a servfail - this is
intended behaviour. You can tweak it a bit with our root-referral flags.

I don't get your situation - you have a powerdns master server that doesn't
contain data, but you want your bind to slave from it?

> > The errors I'm getting in syslog on the powerdns master are:
> > Feb 29 16:40:20 powerdns-dev pdns[13444]: [ID 702911 daemon.warning] Not
> > authoritative for 'hfnmag.com', sending servfail to

This means it is missing the SOA record. Try querying your server directly:

dig -t any hfnmag.com @

Good luck!

http://www.PowerDNS.com      Open source, database driven DNS Software 
http://netherlabs.nl              Open and Closed source services

More information about the Pdns-users mailing list