[Pdns-users] Superslave not working with sqlite3

Mauro Calderara mcalderara at phys.ethz.ch
Wed Jul 9 07:41:10 UTC 2008

Hi everyone

When asking on the IRC channel yesterday 'ahu' told me to send the  
request to the mailinglist. So here we go:

I run pdns 2.9.21, freebsd 7.0, sqlite 3.5.6, compiled from the  
FreeBSD ports-tree. I try to have a bind9 host act as a hidden  
supermaster for some zones. The supermaster is recorded in the  
supermasters-table, but when it sends its notifies powerdns goes:

Jul  9 00:10:17 auth0 pdns[980]: gsqlite3: connection to '/var/db/ 
sqlite3/powerdns.sqlite3' succesful
Jul  9 00:10:17 auth0 last message repeated 2 times
Jul  9 00:10:25 auth0 pdns[980]: Received NOTIFY for domain.tld from for which we are not authoritative
Jul  9 00:10:25 auth0 pdns[980]: Backend error: Database error trying  
to insert new slave 'domain.tld': Error while retrieving SQLite query  

And of course I get a srvfail when querying the server for the domain.

This is, I think, the same as described in http://www.nabble.com/sqlite3-superslave---doesn%27t-work-td13827119.html

In the thread referred to, someone sent a patch and the thread stops  
without stating whether it works or is accepted upstream, so I wanted  
to check for the status of this. I also tested with a svn-version from  
20080625 (also from FreeBSD Ports) and got exactly the same error.

In case the configuration is of relevance, mine is very simple, it  


Thanks in advance,

More information about the Pdns-users mailing list