[Pdns-users] Help, recursor is too slow, mostly doesn't resolve queries

Eugene Pefti eugenep at w3media.net
Mon Apr 28 20:55:00 UTC 2008

Ok, I was away for some time and then when I came back first thing I did was
to enable locally stored root hint file. That seemingly worked. I had a
feeling that pdns-recursor timed out because of that. I might be wrong. But
it worked for me as it greatly reduced the number of "Exception: unknown
escape sequence" message. They are not completely gone from my pdns.info
file by the way. What do they stand for ?

All dig queries seem to work now without big timeouts though. 
These are my rrd graphs to evaluate both recursors:

I run latest pdns-2.9.21 and pdns-recursor-3.5.1 obtained from 
Both nameservers use gmysql backend and I would not say they are loaded too
much. Cpu load is present on one of the graphs.

The number of domains hosted is about 600. Your last question, Bert, about
mixing Authoritative and resolving servers got me unprepared. Is it not
recommended to have them running in one box? I have them listening on
different ports:
PDNS uses port 53 (local-port=53)
And recursor 5300 (recursor=


-----Original Message-----
From: bert hubert [mailto:bert.hubert at netherlabs.nl] 
Sent: Sunday, April 27, 2008 11:30 PM
To: Eugene Pefti
Cc: pdns-users at mailman.powerdns.com
Subject: Re: [Pdns-users] Help, recursor is too slow, mostly doesn't resolve

On Sun, Apr 27, 2008 at 09:00:30PM -0700, Eugene Pefti wrote:
> I would highly appreciate if somebody help me. We rolled out powerdns into
> production mode and after several hours of monitoring I found that the
> recursor is not resolving queries.
> The service restart could help but then again it fails. The only tell-tale
> entry to the log file looks like this:

Could you elaborate please, you provide almost no detail... This is like
going to the doctor and saying 'I feel bad, but I need to leave right now
and I'll come back in 2 weeks, I hope you can tell me what is wrong with me

To help you along:

Do you get that 'unknown escape sequence' error a lot?

When you do non-recursion queries ('dig +norecurs w3media.net
@your-powerdns-server'), do these always work?

When you do recursion queries ('dig ds9a.nl @your-powerdns-server'), what
kind of answers do you get? Timeout? Servfail? NXDOMAIN?

When you query your backend directly for recursive queries, do you get
answers? ('dig ds9a.nl @your-recuror-ip-address') If so, what kind?

What do you use as your recursing backend? PowerDNS? Bind?

Which version of PowerDNS do you run? 2.9.21?

Do you know your query load? (number of queries/second)

Is there anything special about your setup? Custom code, custom pipe
backends, huge number of domains?

Do you really truly need to mix auth and resolving service?


http://www.PowerDNS.com      Open source, database driven DNS Software 
http://netherlabs.nl              Open and Closed source services

More information about the Pdns-users mailing list