[Pdns-users] DS, CERT not working

Seth Mattinen sethm at rollernet.us
Mon Dec 31 21:35:01 UTC 2007

Seth Mattinen wrote:
> I've been experimenting with support for CERT, DS, etc. records in a new 
> pdns installation, but I can't get it to work. I'm using the generic 
> MySQL database with this data:
>     name: ds.50lightyears.com
>     type: DS
>  content: 28668 1 1 49FD46E6C4B45C55D4AC69CBD3CD34AC1AFE51DE
>      ttl: 86400
>     prio: NULL
> (I just used example data from rfc 3658 to populate.)
> However, if I query for the DS record, I don't get anything back. I 
> tried quoting the content field in the davase as well with the same 
> result. I'm using the binary deb "pdns-static_2.9.21-1_amd64.deb". Am I 
> doing something obviously wrong, or is it not really working yet?

Replying to myself... I tried an ANY query (with more logging from pdns) 
and saw this in the log:

Dec 31 21:25:20 ns1-auth pdns[31444]: Exception: Unknown record was 
stored incorrectly, need 3 fields, got 4: "28668 1 1 

A DS query logs this:

Dec 31 21:21:08 ns1-auth pdns[31444]: Authoritative empty NO ERROR to 
208.11.xx.xx for 'ds.50lightyears.com' (#43), other types do exist


More information about the Pdns-users mailing list