[Pdns-users] Recursor not working

Bob Dushok bdushok at gmail.com
Mon Oct 16 14:35:30 UTC 2006

I've having difficulty with connection timeouts with the recursor on my
newest install of PDNS.  I have two PDNS (v2.9.16) servers running on RHEL 4
(32 bit) with a recursor option without a problem.  The new box is running
PDNS (2.9.20) on Suse v10 64 bit.  I'm using a MySQL backend.

Querying any local address works fine.  Remote addresses cause a timeout.

I've added the recursor line to my pdns.conf file as follows:
recursor= (one of my ISPs DNS servers)

I've tried omitting the allow-recursion line (as I have with the two working
boxes) and also have tried it set to  No difference.

At a prompt on the server a query such as dig @
www.google.comreturns an accurate response.  However, the query dig @ www.google.com displays:

<<>> DiG 9.3.2 <<>> @ www.google.com
; (1 server found)
;; global options:  printcmd
;; connection timed out; no servers could be reached

The web server within PDNS shows recursing-questions as a positive number,
one which increases as I enter queries similar to the above.  I see entries
such as "Recursive query for remote with internal id 0 was not
answered by backend within timeout, reusing id".  It would appear PDNS is
having difficulty connecting to my ISP's DNS, but I can do perform this
locally on the server.  The connection is good.

Does anyone have any suggestions?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.powerdns.com/pipermail/pdns-users/attachments/20061016/8a76f4b7/attachment.html>

More information about the Pdns-users mailing list