[Pdns-users] Allegedly invalid "gpgsql-socket" option: connecting to PostgreSQL via UNIX domain socket

Julian Mehnle julian at mehnle.net
Mon May 29 22:54:09 UTC 2006

Hi all,

the documentation of the gmysql/gpgsql backend says[1]:

| gpgsql-dbname
|     Database name to connect to
| gpgsql-host
|     Database host to connect to. [...]
| gmysql-socket (only for MySQL!)
|     Filename where the MySQL connection socket resides.  Often
|     /tmp/mysql.sock or /var/run/mysqld/mysqld.sock.
| gpgsql-password
|     Password to connect with 
| gpgsql-user
|     PgSQL user to connect as

This implies that there is no "gpgsql-socket" option to connect to a 
PostgreSQL server via a UNIX domain socket.  However, having become suspi- 
cious of the incorrect documentation in the case of the "bind-example- 
zones" option, I again read the source and then tried setting the "gpgsql- 
socket" option instead of the "gpgsql-host" option, and lo and behold, it 
worked!  (Remember, UNIX sockets are far more efficient than loopback TCP 

I wonder what other inaccuracies the docs contain. :-(


 1. http://doc.powerdns.com/generic-mypgsql-backends.html#AEN4500
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://mailman.powerdns.com/pipermail/pdns-users/attachments/20060529/de53ed9a/attachment.sig>

More information about the Pdns-users mailing list