[Pdns-users] "pdns monitor" works but not "pdns start"

isc10906 isc10906 at nus.edu.sg
Sun Nov 23 15:38:23 UTC 2003

Thank you for your reply Bert and my apologies for forgetting the

I am already compiling from the 2.9.12 GPL sources under Redhat Linux
7.3 when I ran into this problem. My server is aliased with 8 IP
addresses and I had bound PDNS to the IP address via the
"local-address" parameter inside pdns.conf.

I've played around with pdns_server binary and here's what I gathered:

1. pdns_server --daemon=yes -guardian=yes

'ps' shows pdns running, but nmap does not show pdns listening 

2. pdns_server --daemon=no --guardian=yes
Hangs after the following is displayed:

Nov 23 23:25:53 Listening on controlsocket in
Nov 23 23:25:53 Guardian is launching an instance

'ps' shows:

24445 pts/5    S      0:00 pdns_server --daemon=no --guardian=yes
24446 pts/5    Z      0:00 [pdns_server <defunct>]
24448 pts/5    S      0:00 pdns_server --daemon=no --guardian=yes

3. pdns_server --daemon=no --guardian=no

Startup messages appear as normal, works perfect together with mysql
backend and queries are correctly answered.

I've tried the tcpdump method you suggested, but it does not pick up
anything. Pardon me if this should not be the case, I am still a novice
network enthusiast and is not familiar with this facility.

Hope these details will be useful in your isolating of the problem.

Thank you very much!



-----Original Message-----
From: bert hubert [mailto:ahu at ds9a.nl] 
Sent: Sunday, November 23, 2003 9:46 PM
To: isc10906
Cc: pdns-users at mailman.powerdns.com
Subject: Re: [Pdns-users] "pdns monitor" works but not "pdns start"

On Sat, Nov 22, 2003 at 03:05:29PM +0800, isc10906 wrote:

> However when I do a "service pdns start", a dig at the same IP address
> reports "no servers could be reached" but a nmap scan shows that PDNS
> listening on port 53 of the IP address.

This has been reported once before. One thing, do you have multiple IP
addresses? Do you bind to them specifically or do you bind to

Can you try compiling PowerDNS yourself instead of using the rpm?

Can you run tcpdump -c -n port 53 -s 0 while you run dig?


http://www.PowerDNS.com      Open source, database driven DNS Software 
http://lartc.org           Linux Advanced Routing & Traffic Control

More information about the Pdns-users mailing list