[Pdns-users] How add DS record to authoritative powerdns?

Jacob Bunk Nielsen jbn at one.com
Thu Dec 8 05:14:07 UTC 2022

On 08/12/2022 02.15, Nick Urbanik via Pdns-users wrote:
> I am working with DNSEC and in my lab setup I need to add a DS record 
> to my parent domain, and don't see how to do that.

What do you consider your domain and your parent domain in your setup?

If your domain is example.com, your parent domain is com, and you need 
to add the DS record to the com zone through your registrar.

> I am using PowerDNS version 4.7.2 on Fedora 37 with a BIND backend, 
> using sqlite using the command:
> pdnsutil create-bind-db...
> I have tried adding the DS record to the BIND zone text, and also 
> using |pdnsutil add-record...|

What exactly did you do and which error messages did you get?

What are the steps you have tried in order to debug the issue and which 
output did they produce?

Best regards,

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.powerdns.com/pipermail/pdns-users/attachments/20221208/e99a92c7/attachment.htm>

More information about the Pdns-users mailing list