[Pdns-users] stupid recursor question

Curtis Maurand curtis at maurand.com
Tue Dec 6 17:06:22 UTC 2022

I've been a pdns user since, well, forever.  I abandoned bind long ago.  
I currently have a set up where I run an authoritative server on a 
virtual machine and I run pdns-recursor on a separate virtual machine.

On the authoritative server I host a domain that I'll call domain.tld as 
the example.  It works fine. It returns all of the correct answers and 
the zone is signed and those answers come back correctly.

queries to outside recursors such as or or, 
return appropriate responses.  All seems to be well, until I query the 
local recursor which returns nothing.  It answers, but doesn't return a 
response.  The local networks are set up  in the recursor.conf 

querying a foreign domain such as ibm.com or microsoft.com works fine.  
It just seems to be my local recursor is finding nothing that I actually 
host.  I've tried forward-zones = domain.tld=; and that 
doesn't seem to work.

Does anyone have any ideas?

Thank in advance,

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.powerdns.com/pipermail/pdns-users/attachments/20221206/6c191246/attachment.htm>

More information about the Pdns-users mailing list