[Pdns-users] PDNS and Isilon Smartconnect Delegation

Ian Easter ieaster at telvue.com
Thu Dec 13 19:17:23 UTC 2018

Recently switched from BIND9.7.3 to PowerDNS and working through some

We previously followed the guidelines for DNS based on the documentation:
and everything worked without issue.

Translating that to PowerDNS seems to be a bit more challenging at the

Adding the same records to PowerDNS are just returning the Isilon SIP A
address record IP rather then the round robin IP address from the Isilon

At this point, I'm either looking in the wrong place, wrong keywords, or
just simply not understanding why this isn't working.

I did find an old thread regarding this matter but it did not seem to end
with a resolution.  I had also ran down another thread regarding a similar
matter which started leading me toward needing to look at configuring
pdns-recursor for this but I can't get anything to work on either front.

Greatly appreciate any assistance.

Current records set on PowerDNS (as they worked on BIND)
isilon-nfs              NS      isilon-nfs-sip
isilon-nfs-sip          A

What dig reports

; <<>> DiG 9.10.6 <<>> isilon-nfs.teve.inc @
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 15456
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 2
;; WARNING: recursion requested but not available

; EDNS: version: 0, flags:; udp: 1680
;isilon-nfs.teve.inc.           IN      A

isilon-nfs.teve.inc.    3600    IN      NS      isilon-nfs-sip.teve.inc.

isilon-nfs-sip.teve.inc. 3600   IN      A

;; Query time: 18 msec
;; WHEN: Thu Dec 13 14:14:02 EST 2018
;; MSG SIZE  rcvd: 93

*Thank you,*
*Ian Easter*
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.powerdns.com/pipermail/pdns-users/attachments/20181213/12ef85fd/attachment.html>

More information about the Pdns-users mailing list