[Pdns-users] Installing PowerDNS 4.x authorative server on Debian Jessie

Volker Janzen volker at janzen.onl
Mon Aug 1 11:05:08 UTC 2016


today I wanted to update my PowerDNS authorative cluster from 3.x to 4.x. After reviewing the upgrade instructions I found no database changes (mysql backend), so I decided to proceed. As of my cluster is still on Debian wheezy, I wanted to upgrade to Jessie before upgrading PowerDNS.

The update of the master seem to have worked fine, until I rebooted the VM. PowerDNS failed to start.

My beloved systemd / journalctl companions failed to show the reason why the authorative server did not start.

I then simpy tried on command line to start the server:

root at pdns:~# pdns_server
pdns_server: error while loading shared libraries: libboost_serialization.so.1.49.0: cannot open shared object file: No such file or directory

I'm not sure how to solve this issue. Debian online package search shows up there should be a library of this version in Jessie, but when clicking the package it shows an error, this version is not installable in current Jessie as far as I can say.

Is there some kind of dependency problem in PowerDNS?

I followed these instructions with using the PowerDNS repo: https://doc.powerdns.com/md/authoritative/installation/


More information about the Pdns-users mailing list