[Pdns-users] AXFR Crashses

Mark Moseley moseleymark at gmail.com
Fri Feb 27 22:15:12 UTC 2015

We don't do a lot (or practically any) AXFRs, so I hadn't noticed this
before now.

For every domain of ours that I've tried, doing an AXFR (to a pdns running
on localhost -- mysqld running on localhost too; running the powerdns
ubuntu precise package for 3.4.2, not running dnssec), it appears to crash
the server. The database was massaged from a 2.9.x era database, so could
easily be something there. I tried trimming the below domain down to
literally a single record (to make sure it wasn't garbage in other records):

mysql> select * from records where domain_id = 6084603\G
*************************** 1. row ***************************
         id: 688982903
  domain_id: 6084603
       name: example2.com
       type: SOA
    content: ns1.example2.com dnsadmin.example2.com 2015022701 10800 3600
604800 3600
        ttl: 3600
       prio: NULL
change_date: 1425073508
   disabled: 0
  ordername: NULL
       auth: 1
1 row in set (0.00 sec)

Here's the logs:

gmysql Connection successful. Connected to database 'dns' on ''.
AXFR of domain 'example2.com' initiated by
AXFR of domain 'example2.com' allowed: client IP is in
gmysql Connection successful. Connected to database 'dns' on ''.
gmysql Connection successful. Connected to database 'dns' on ''.
Got a signal 11, attempting to print trace:
/usr/sbin/pdns_server-instance() [0x65c4d0]
/lib/x86_64-linux-gnu/libc.so.6(+0x36150) [0x6c3d088cd150]
/usr/sbin/pdns_server-instance(_ZNSs6assignERKSs+0x24) [0xa68424]
/lib/x86_64-linux-gnu/libpthread.so.0(+0x7e9a) [0x6c3d08c5de9a]
/lib/x86_64-linux-gnu/libc.so.6(clone+0x6d) [0x6c3d0898a8bd]
Our pdns instance (11029) exited after signal 6
Guardian is launching an instance
Reading random entropy from '/dev/urandom'
This is a guarded instance of pdns
Listening on controlsocket on ''
Only allowing TCP control from:,
UDP server bound to
TCP server bound to
PowerDNS Authoritative Server 3.4.2 (jenkins at autotest.powerdns.com) (C)
2001-2015 PowerDNS.COM BV
Using 64-bits mode. Built on 20150203085343 by root at autotest.powerdns.com,
gcc 4.7.2.

Attaching to gdb yields this:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x6a376dc97700 (LWP 4618)]
0x0000000000654087 in endsOn(std::string const&, std::string const&) ()
(gdb) bt
#0  0x0000000000654087 in endsOn(std::string const&, std::string const&) ()
#1  0x0000000000611d07 in TCPNameserver::doAXFR(std::string const&,
boost::shared_ptr<DNSPacket>, int) ()
#2  0x00000000006181ad in TCPNameserver::doConnection(void*) ()
#3  0x00006a3897018e9a in start_thread () from
#4  0x00006a3896d458bd in clone () from /lib/x86_64-linux-gnu/libc.so.6
#5  0x0000000000000000 in ?? ()

Any idea what's making it unhappy? I've got no issues with the current
server otherwise.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.powerdns.com/pipermail/pdns-users/attachments/20150227/8876c941/attachment.html>

More information about the Pdns-users mailing list