[Pdns-users] Unable to connect to SQLite database does not exist yet

Lists lists at lolling.org
Thu Aug 28 19:48:50 UTC 2014


I am new to PDNS and trying to use the SQLite backend as per the 
instructions on http://doc.powerdns.com/html/gsqlite.html.

I am running SQLite version 3.6.20 with PowerDNS Authoritative Server 
3.3.1 on CentOS release 6.5

I have installed SQLite, created the database and can list the tables 
which I created as per the instructions above.

I have added the following to pdns.conf:


I have also tried changing permissions and ownership of my pdns database 
file, thinking it was a permissions issue but I still get the following 
errors in /var/log/messages.

gsqlite3: connection failed: SQLite database '/root/pdns.db' does not 
exist yet
Caught an exception instantiating a backend: Unable to launch gsqlite3 
connection: SQLite database '/root/pdns.db' does not exist yet

And when I try to use poweradmin to configure pdns with the SQLite 
backend, on Installation step 4, I get.

Updating database... Unable to connect to the database server. Please 
report the problem to an Administrator.

Does anyone know what is causing this problem and how to fix it?


More information about the Pdns-users mailing list