[Pdns-users] Building pdns RPMs using custom LDAP libraries/headers

Ruben Kerkhof ruben at rubenkerkhof.com
Tue Apr 9 18:04:50 UTC 2013

On Tue, Apr 9, 2013 at 4:15 PM, Nikolaos Milas <nmilas at admin.noa.gr> wrote:

> To make things clearer, I started again from scratch; I downloaded
> http://www.monshouwer.eu/**download/3rd_party/pdns-**
> server/el6/SRPMS/pdns-server-**3.2-1.el6.MIND.src.rpm<http://www.monshouwer.eu/download/3rd_party/pdns-server/el6/SRPMS/pdns-server-3.2-1.el6.MIND.src.rpm>and I tried to build in a new user account, with:
>    $ cat ~/.rpmmacros
>    %_topdir %(echo $HOME)/rpmbuild
> as I usually do when building.
> Now, I tried to build the above, WITHOUT ANY MODIFICATIONS WHATSOEVER, on
> CentOS 6.4 (kernel: 2.6.32-358.2.1.el6.x86_64) and it always fails at the
> same point (i.e. it can't find the standard ldap libraries, although they
> exist on the system - as I have described in the beginning of the thread):
>    checking for ldap_set_option in -lldap_r... no
>    checking for ldap_set_option in -lldap... no
>    configure: error: ldap library (libldap) not found
> I think we should focus on solving the problem why we can't build with the
> unmodified SRPM, using standard system libraries.

Hi Nikolaos,

I haven't followed this thread closely, so I don't know what you're trying
to accomplish, but powerdns is in the EPEL repo too.
The src.rpm is at
http://dl.fedoraproject.org/pub/epel/6/SRPMS/pdns-3.1-2.el6.src.rpm, try
that one.

Kind regards,

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.powerdns.com/pipermail/pdns-users/attachments/20130409/2b7845be/attachment-0001.html>

More information about the Pdns-users mailing list