[Pdns-users] Pdns python pipe

José Arthur Benetasso Villanova jose.arthur at gmail.com
Thu May 10 23:26:23 UTC 2012


Have you tried this script with user "pdns"?

Like Peter said, it can be an env issue. Since pdns does not start a login
process, some stuff that PAM or something else set could not be loaded.

A "root root rwx------" permission in the wrong place can cause the same

If SELinux is active, it can cause some errors like this one.

José Arthur Benetasso Villanova

 Thu, May 10, 2012 at 9:23 AM, Peter van Dijk
<peter.van.dijk at netherlabs.nl>wrote:

> Hello,
> On May 10, 2012, at 13:51 , dfedorov wrote:
> > The backend script fails on
> > import MySQLdb,
> > commenting this string resolves the problem.
> > Starting the script from the command line gives no errors, i've tried to
> > send messages to it from stdin and got correct responses to stdout.
> > Any suggestions?
> Any environmental difference can explain this issue. Are you developing in
> a virtualenv? Do you have PYTHONPATH set when developing?
> Kind regards,
> --
> Peter van Dijk
> Netherlabs Computer Consulting BV - http://www.netherlabs.nl/
> _______________________________________________
> Pdns-users mailing list
> Pdns-users at mailman.powerdns.com
> http://mailman.powerdns.com/mailman/listinfo/pdns-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.powerdns.com/pipermail/pdns-users/attachments/20120510/830e72d7/attachment-0001.html>

More information about the Pdns-users mailing list