[Pdns-users] 3.0-RC2 crash on sending notify

Charles Sprickman spork at bway.net
Sun May 29 07:38:39 UTC 2011

I'll top post since the answer is so simple...

For testing I just threw the sqlite db file in my config dir, 
/usr/local/etc/pdns and made it owned by the pdns user.  This works fine 
for reading, but apparently something in the process of sending a notify 
requires a write to the db, and it looks like sqlite wants to write a temp 
file or something in that directory.  If it can't, the query fails.  If 
the query fails, then I get my "crash".

Making a subdir in my conf dir, moving the db there and making the 
directory owned by the db user let me successfully send a notify using 
sqlite on the master.

I discovered this when working on my slave and seeing it throw an error on 
an inbound axfr.  The logging there was quite obvious - it couldn't open 
the file for writing.

Still baffled by the logging thing though...



On Sun, 29 May 2011, Charles Sprickman wrote:

> On Fri, 27 May 2011, bert hubert wrote:
>> On Thu, May 26, 2011 at 11:06:16PM -0400, Charles Sprickman wrote:
>>> various values for loglevel from 5 all the way up to 999 and never saw
>>> an increase in verbosity), so I tried launching powerdns from gdb, just
>>> to see if I could get more of a hint about what was happening.  This is
>>> what I see when running "pdns_control notify pdnsexample.com":
>> I tried to reproduce here, and I don't see it. However, your error 
>> reporting
>> is very convincing, so the problem is probably real.
>> Can you send me your pdns-test.db? That would make life a lot easier.
>> Also, can you tell me which version of sqlite you compile against?
>>> The one thing I see here that I didn't see in the log was the "Unable to
>>> close down sqlite connection: 5" message.
>> This is an error we used to let pass by w/o shutting down. It turns out 
>> that
>> it causes subsequent unrelated problems if you do that, which is why we
>> terminate immediately when we see this, so we get helpful email messages
>> like this ;-)
>>> Any ideas?  I understand 3.0 is not production yet, so I'm not sure how
>>> much confidence to place in it - in other words, is this me or is this 
>>> PDNS?
>> It is powerdns in all likelihood. Please send a sqlite3 database that
>> exhibits the problem.
> Just checking in - I went ahead and set my master up to use pgsql for the 
> backend and notifies and transfers are working fine.  The slave is running 
> sqlite and it's able to handle the incoming transfer without issue.  Not sure 
> if that helps or not, but I can tell you both servers are running the same 
> build of PowerDNS and SQLite.
> Logs of the successful notify and axfr on the sqlite slave:
> ---
> May 29 05:38:09 pdns2 pdns[90220]: Received NOTIFY for pdnsexample.com from 
> x.x.x.38 for which we are not authoritative
> May 29 05:38:09 pdns2 pdns[90220]: Created new slave zone 'pdnsexample.com' 
> from supermaster x.x.x.38, queued axfr
> May 29 05:38:09 pdns2 pdns[90220]: Initiating transfer of 'pdnsexample.com' 
> from remote 'x.x.x.38'
> May 29 05:38:09 pdns2 pdns[90220]: gsqlite3: connection to 
> '/usr/local/etc/pdns/sqlite/pdns-test.db' successful
> May 29 05:38:09 pdns2 last message repeated 2 times
> May 29 05:38:09 pdns2 pdns[90220]: No serial for 'pdnsexample.com' found - 
> zone is missing?
> May 29 05:38:09 pdns2 pdns[90220]: AXFR started for 'pdnsexample.com', 
> transaction started
> May 29 05:38:10 pdns2 pdns[90220]: AXFR done for 'pdnsexample.com', zone 
> committed
> ---
> Thanks,
> Charles
>> 	Bert
> _______________________________________________
> Pdns-users mailing list
> Pdns-users at mailman.powerdns.com
> http://mailman.powerdns.com/mailman/listinfo/pdns-users

More information about the Pdns-users mailing list