[Pdns-users] Status of the LDAP backend in 3.0 release

Nick Milas nmilas at admin.noa.gr
Mon May 16 08:39:38 UTC 2011

On 15/5/2011 12:47 ΌΌ, Nick Milas wrote:

> I saw the 2193 tarball. I'll try to compile and test it tomorrow 
> (Monday).

I am having a hard time trying to compile it. I installed (from CentOS 
repos) boost:


but I was getting:

    checking for Boost headers version >= 103400... no
    configure: error: cannot find Boost headers version >= 103400

Then, I saw that boost-devel files are in /usr/include/boost and I tried 

    CXXFLAGS=-I/usr/include/boost ./configure --with-modules="gmysql ldap"

or with:

    CXXFLAGS=-I/usr/include ./configure --with-modules="gmysql ldap"

but I kept getting the same error. So, I downloaded the source package 
from boost website, extracted it and tried with (as suggested here: 

    CXXFLAGS=-I/root/boost/boost_1_46_1 ./configure
    --with-modules="gmysql ldap"

With it, I am getting:

    checking for Boost headers version >= 103400... yes
    checking for Boost's header version... 1_33_1
    checking boost/foreach.hpp usability... yes
    checking boost/foreach.hpp presence... no
    configure: WARNING: boost/foreach.hpp: accepted by the compiler,
    rejected by the preprocessor!
    configure: WARNING: boost/foreach.hpp: proceeding with the
    compiler's result
    checking for boost/foreach.hpp... yes
    checking for the toolset name used by Boost for g++... gcc41 -gcc
    checking boost/program_options.hpp usability... yes
    checking boost/program_options.hpp presence... yes
    checking for boost/program_options.hpp... yes
    checking for the Boost program_options library... no
    configure: error: cannot not find the flags to link with Boost

Why the configure script didn't find the boost headers as installed by 
the native RPM package?
(See the package contents at 

Why the source package didn't work either?

Please advise!

Note: I only have x86_64 packages installed in the box.


More information about the Pdns-users mailing list