[Pdns-users] need help setting up pdns

Liong Kok Foo kokfoo.liong at innity.com
Wed Jan 20 09:59:47 UTC 2010


I am new to pdns and is currently converting the current dns running 
bind9 to pdns.

I have successfully setup pdns in centos 5.3 running a pdns version 
downloaded from dag wieers repository. Apparently this rpm does not need 
a separate mysql backend rpm. It is using poweradmin.

Anyway, it seems to be working and I have moved some of the domains 
using zone2sql. Some domains does not get converted by zone2sql due to 
something in the zone file that zone2sql.

Anyway, I have tried testing with dig query and there seems to be some 
reply from the pdns. Looks like it is working.

But if I run the query from my local desktop windows using nslookup 
command, i will get some error. Here is what i did :
under windows xp machine command prompt:
C:\Documents and Settings\admin>nslookup
Default Server:  current.home.com

 > server ns0.domain.com
Default Server:  ns0.domain.com

 > test.com
Server:  ns0.domain.com

Name:    test.com
Results looks okay from nslookup.

But in the pdns server log file, i tail the /var/log/messages:

Jan 20 17:31:55 domainvn pdns[21108]: Not authoritative for 
'test.com.HOME.COM', sending servfail to 111.222.333.444 (recursion was 

Where 111.222.333.444 is external ip for my current internet connection.

Any ideas? Does this means the pdns setup is having some problem? Please 
let me know if anyone willing to login to look at my poweradmin.


More information about the Pdns-users mailing list