[Pdns-users] Powerdns and qmail CNAME lookup error

Alex Lannon alannon at gmail.com
Thu Nov 5 15:31:43 UTC 2009

Hello, I am currently running into issues with powerdns and qmail.  Running
'ANY' queries is returning no results which seems to be causing issues with
qmail servers (yahoo.com specifically).  When qmail attempts to query the
server before sending email, a CNAME error is being returned to the sender
(see below):
Hi. This is the qmail-send program at yahoo.com.
I'm afraid I wasn't able to deliver your message to the following addresses.
This is a permanent error; I've given up. Sorry it didn't work out.

<user at legitimatedomain.com>:
CNAME lookup failed temporarily. (#4.4.3)
I'm not going to try again; this message has been in the queue too long.

and ANY request:

# dig legitimatedomain.com ANY +noall +answer

; <<>> DiG 9.5.1-P3 <<>> legitimatedomain.com ANY +noall +answer
;; global options:  printcmd

Server info:
Debian Lenny - amd64
kernel: 2.6.26-2-amd64
pdns version:
ii  pdns-backend-mysql                       generic
MySQL backend for PowerDNS
ii  pdns-doc                                 PowerDNS
ii  pdns-server                              extremely
powerful and versatile nameserver

I ran into this same issue a few months back and the solution at the time
was to remove the 'IN A' wildcard record that I previously had in place.
Everything was fine for about two weeks and now... same error.

As there are no CNAME records for the domain in question, we are receiving
email from non-qmail servers, and it's not likely that yahoo will patch
their qmail, I am at a loss and looking to you for help.

Please let me know what else I can do to troubleshoot and resolve this

Thank you!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.powerdns.com/pipermail/pdns-users/attachments/20091105/fdc38cdc/attachment.html>

More information about the Pdns-users mailing list