[Pdns-users] pdns-recursor on Solaris

Anatoliy Kushner lamazavra at gmail.com
Wed Jul 2 02:55:19 UTC 2008

I rebuild it with boost 1.33, and all is seems ok. Now i run it and testing.
Thank you.

ns3:~/pdns-recursor-3.1.7> g++ -v
Reading specs from /usr/local/lib/gcc/sparc-sun-solaris2.10/3.4.6/specs
Configured with: ../configure --with-as=/usr/ccs/bin/as
--with-ld=/usr/ccs/bin/ld --enable-shared --enable-languages=c,c++,f77
Thread model: posix
gcc version 3.4.6
ns3:~/pdns-recursor-3.1.7> uname -a
SunOS ns3 5.10 Generic_127111-11 sun4u sparc SUNW,Sun-Fire-V440

2008/7/1 bert hubert <bert.hubert at netherlabs.nl>:
> On Tue, Jul 01, 2008 at 09:43:08PM +0600, Anatoliy Kushner wrote:
>> May be you can help me. I try build pdns-recursor , but alweys catch
>> the same error.
> Odd - this appears to be a mixup between boost and Solaris:
>> recursor_cache.hh:36: error: use of `uint32_t' is ambiguous
>> /usr/include/sys/int_types.h:74: error:   first declared as `typedef
>> unsigned int uint32_t' here
>> /export/home/akushner/boost_1_35_0/boost/cstdint.hpp:239: error:
>> also declared as `typedef long unsigned int boost::uint32_t' here
>> recursor_cache.hh:36: error: `uint32_t' has not been declared
> This is wrong. Can you try another version of boost? Perhaps 1.34? What is
> the output of g++ -v? Which Solaris version is this?
>        Bert
> --
> http://www.PowerDNS.com      Open source, database driven DNS Software
> http://netherlabs.nl              Open and Closed source services

More information about the Pdns-users mailing list