[Pdns-users] "Additional Section" with A records in NS lookups missing?

John Morris pdns at butchwax.com
Tue Mar 21 22:59:26 UTC 2006

Wow, speedy reply!

> > I've just noticed a problem with my domain.  The nifty tool at
> > http://www.dnsreport.com/ tests for A records returned on NS queries.
> > See the following (edited) output from dig; powerdns.com does,
> > zultron.com doesn't:
> This might be a bug in the LDAP backend. Can you dump the content of your
> 'zultron' zone?

Hmm, seems I can't.  Never tried before since I use LDAP replication to
propagate changes.  I turned on 


and saw this:

        $ dig @ zultron.com axfr
        ; <<>> DiG 9.2.4 <<>> @ zultron.com axfr
        ;; global options:  printcmd
        ; Transfer failed.

> Try 'out-of-zone-additional-processing' - it will probably solve your
> problem, but hide the bug. 

Tried this too:


But still see the same problem:

        $ dig @ns1.zultron.com zultron.com ns
        ;zultron.com.                   IN      NS
        ;; ANSWER SECTION:
        zultron.com.            3600    IN      NS      ns1.zultron.com.
        zultron.com.            3600    IN      NS      ns2.zultron.com.
Thank you!


More information about the Pdns-users mailing list