[Pdns-users] LDAP compile error (openldap-2.3

Dean Baender dean at dyerdigital.com
Mon Apr 24 22:53:52 UTC 2006

On Monday 24 April 2006 2:39 pm, Szabo Akos wrote:
> Hi,
> > I just ran into this problem as well.
> > I'm using Gentoo Linux & openldap-2.3.20 but I suspect the fix holds for
> > anyone using any 2.3.x version of openldap.
> >
> > Sorry if this is a known fix, but I didn't see a solution on the list, so
> > here's what I came up with:
> You are right, now I can use the ldap backend, and I can upgrade my
> pdns :) Thanks!

Excellent!  I'm glad it worked for you too.

> Only the first patch is usefull, the second one is already applied in
> tha mainstream soources.

I'm not sure what you mean by the "mainstream sources"... Do you mean 

In any case I should've been more clear about where each patch is used.
Only one patch is needed, which one depends on where the pdns sources came 

Patch 1: Apply to a public powerdns release.
> > ldap-2.3-fix.patch
> > 	Adds -DLDAP_DEPRECATED to ldapbackend/Makefile.in & .am
> > 	apply to a released powerdns (I've only tried 2.9.18 & 2.9.20)

Patch 2: Only apply to pdns development tree
(see  http://wiki.powerdns.com/projects/trac/wiki/HACKING for details)
> > svn-ldap-2.3-fix.patch
> > 	Adds -DLDAP_DEPRECATED to ldapbackend/Makefile.am
> > 	made from svn rev 759
> >
> > I hope someone will find this useful.
> Thank You again!
My pleasure.


More information about the Pdns-users mailing list