[Pdns-users] Delegation broken?

Michael Loftis mloftis at wgops.com
Wed Nov 23 00:59:29 UTC 2005

--On November 23, 2005 12:15:51 AM +0100 bert hubert 
<bert.hubert at netherlabs.nl> wrote:

> On Tue, Nov 22, 2005 at 04:09:23PM -0700, Michael Loftis wrote:
>> Why do I have broken delegation wit the below records.  I was notified
>> of  this problem by the customer.  PowerDNS should be returning NS
>> records,  instead it returns SOA for parentdomain.org instead of the
>> three NS for  sub.paren.org  -- i've changed the actual domains involved
>> in the below  records but that's it.  Using gmysql backend, mysql 4.1.11
>> and powerdns  2.9.19 on Debian Woody (3.0) *and* RedHat 7.3 testing box,
>> both produce the  same result.
> This problem is solved in commit
> http://wiki.powerdns.com/projects/trac/changeset/539
> We'll release a fixed version of PowerDNS shortly.
> For instructions on applying, please see
> http://wiki.powerdns.com/projects/trac/wiki/HACKING
> Apologies.

Still broken.  Atleast now it isn't returning the SOA for the wrong zone, 
but it's still not returning any NS records.

More information about the Pdns-users mailing list