[Pdns-users] Superslave operation and sqlite backend

Miroslaw Majorek pdns-users at avwx.com
Wed Jun 22 15:18:51 UTC 2005


I am trying to set up PowerDNS with sqlite backend to act as a 
superslave. The master is also a PowerDNS running off a MySQL backend. 
The slave is running CentOS 4 and no other servers are running (except 
OpenSSH). I added the master to supermasters table, the slave is a 
registered name server for the zone (both in the NS records at the 
master and at the registrar - parent zone). Sqlite is configured fine, 
PowerDNS starts up fine (no strange messages) and connects to the sqlite 
file just fine (pdns[4216]: gsqlite: connection to 
'/etc/powerdns/powerdns.sqlite' succesful).

I add the zone to the master table, PowerDNS on the master notices it 
and sends a transfer to the slave. The slave receives it, but does not 
write the zone to the database. The log on the slave contains the following:

Jun 21 14:44:10 mesaana pdns[4218]: Received NOTIFY for domain.net from 
<MASTER IP> for which we are not authoritative
Jun 21 14:44:10 mesaana pdns[4218]: Unable to find backend willing to 
host domain.net for potential supermaster <MASTER IP>

I tried to look for a solution to this problem. Someone on this list 
suggested the permissions. I checked the permissions on the 
/etc/powerdns/powerdns.sqlite database file, these are fine. I changed 
the permissions to 666 just in case there was a permissions problem. 
Then I run PowerDNS as root (disabled uid and gid), still no joy.

First I installed PowerDNS binary distribution (version 2.9.17 static) 
downlaoded from powerdns.com, then I downloaded the source and 
recompiled, but still the same effect. I also checked the source code 
and the relevant supermaster/superslave queries have been defined for 
sqlite backend.

Any ideas?


More information about the Pdns-users mailing list