[Pdns-users] Questions About Authority

Anthony Eden anthony at sdc-hawaii.co.mp
Thu Nov 11 21:18:26 UTC 2004


Thanks for your quick response.  Could you tell me exactly what tcpdump 
command line options you are interested in?  I've tried running the 

  tcpdump -vvv -i eth0:0 -l port domain

But we are getting so much useless DNS traffic coming in that it is 
impossible for me to interpret the results.  I've also tried running:

tcpdump -vvv -i eth0:0 -l port domain | grep lava

Since our upstream provider here at the office is lava.net.  That 
produces better results:

07:07:59.232217 cust18739.lava.net.32783 > [udp 
sum ok]  19312+ ANY? testdomain2.mp. (32) (DF) (ttl 55, id 0, len 60)
07:07:59.234060 > cust18739.lava.net.32783: 
19312*- q: ANY? testdomain2.mp. 5/0/3 testdomain2.mp. A, 
testdomain2.mp.[|domain] (DF) (ttl 64, id 0, len 237)
07:08:10.613633 cust18739.lava.net.32783 > [udp 
sum ok]  62958+ A? sunrise.mp. (28) (DF) (ttl 55, id 0, len 56)
07:08:10.613859 > cust18739.lava.net.32783: [udp 
sum ok]  62958*- q: A? sunrise.mp. 1/0/0 sunrise.mp. A 
(44) (DF) (ttl 64, id 0, len 72)

07:09:09.944334 cust18739.lava.net.32783 > [udp 
sum ok]  40603+ A? sunrise.mp. (28) (DF) (ttl 55, id 0, len 56)
07:09:09.944935 > cust18739.lava.net.32783: [udp 
sum ok]  40603*- q: A? sunrise.mp. 1/0/0 sunrise.mp. A 
(44) (DF) (ttl 64, id 0, len 72)
07:09:48.800972 cust18739.lava.net.32783 > [udp 
sum ok]  4048+ A? foobar.mp. (27) (DF) (ttl 55, id 0, len 55)
07:09:48.801664 > cust18739.lava.net.32783: [udp 
sum ok]  4048*- q: A? foobar.mp. 1/0/0 foobar.mp. A (43) 
(DF) (ttl 64, id 0, len 71)

The results above are from the ns2.nic.mp which is currently running 
PowerDNS on port 53.  However when I try the same command on ns1.nic.mp 
which has Bind running on port 53 I get no results even though the query 
  from dig is exactly the same, for example:

dig @ sunrise.mp for ns2.nic.mp versus
dig @ sunrise.mp for ns1.nic.mp

Both queries were issued from the same machine.  Thanks for spending 
your valuable time on this, I really appreciate it.

Anthony Eden

bert hubert wrote:
> On Thu, Nov 11, 2004 at 09:34:45AM -1000, Anthony Eden wrote:
>>I've tried setting up PowerDNS to first check the bind backend and then 
>>use the pipe backend to a Perl script if a result is not found in the 
>>bind data.  I am running PowerDNS installed from the RPM 
>>pdns-static-2.9.16-1.i386.rpm on RedHat 9.
> Hehe cool!
>>Yesterday I enabled this configuration on port 53 in the production 
>>environment.  I then went to a machine on the RoadRunner network (their 
>>DNS servers have the delegation-only patch applied so they are a good 
>>test) and lo and behold nothing resolved, not even the names which are 
> I'm currently very busy, may I suggest that you run tcpdump on your server
> with -v -v -v and send me the results? Ask the RoadRunner nameservers a new
> question and see what questions they ask you, and what answers powerdns
> returns. Those results will help me help you.

More information about the Pdns-users mailing list