[Pdns-users] pdns slaving from bind9

Mark Jeftovic markjr at easydns.com
Tue May 13 00:45:37 UTC 2003

[sorry if this shows up twice, I think I originally posted from
 the wrong email addy -m ]

We're testing pdns now, at the moment running it as a slave from a
bind9 primary.

It doesn't look like pdns is responding to NOTIFY packets, also
if I try to force a refresh using pdns_control retrieve <domain>
it says its scheduling a retrieval request for <domain> but it
still does not pull the new info down. (Perhaps its waiting
for the REFRESH interval to elapse regardless?)

Sifting through the archives I've tried strict-rfc-axfrs=yes and
strict-rfc-axfrs=no, neither seems to impact this.

I can verify that the pdns server is able to do axfers from the primary
(as eventually the zone will come down) and it adds new domains from
the looks of it (as the primary is set to a supermaster)

disable-axfr=yes is set, right now no allow-axfr-ips are set because
setting it opens up axfr's from anywhere (seemingly a bug already
mentioned on list).

guardian=yes, daemon=no would those affect this? (I've tried them
either way).

Are there any other switches or settings that would have an effect here?


mark jeftovic

More information about the Pdns-users mailing list