[dnsdist] Dnsdist and dnstap doesn't work

Eduard Ahmatgareev e.ahmatgareev at gmail.com
Sun Sep 16 16:54:01 UTC 2018

Hi everyone,

Thanks for that powerful software - dnsdist. I tried to use new
functionality: dnstap
for that I added additional configuration:
fslu = newFrameStreamUnixLogger('/tmp/dnstap.sock')
addAction(AllRule(), DnstapLogAction("a.server", fslu))

and restart service, but when tried to find sock file, couldn't find it:
root at dns-balance:~# ll /tmp
total 4
drwx------ 3 root root 4096 Sep 16 16:51
root at dns-balance:~#

the same I did on freebsd OS 11.3, builded dnsdist with support: fstrm
and tried to add dnstap from console, and it didn't work too.

Does it possible to do debug, to find  a reason why sock file wasn't create?
my current version is:

root at dns-balance:~# dnsdist -V
dnsdist 1.3.2 (Lua 5.2.4)

os: Linux Debian 9 latest.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.powerdns.com/pipermail/dnsdist/attachments/20180916/02a12201/attachment.html>

More information about the dnsdist mailing list